图片 7

悬镜安全精心筛选过去一周全球安全大事,其中有3个漏洞的安全影响评级(SIR)为

原标题:悬镜安全 | 第七期 全球一周安全情报(0903-0909)

按照思科的惯例,他们会在每年的3月和9月披露Cisco IOS和Cisco
IOS-XE操作系统中存在的安全漏洞。思科于上周六发布的IOS及IOS
XE软件安全公告共包含了20项安全更新咨询,涉及22个安全漏洞。其中有3个漏洞的安全影响评级(SIR)为“关键(Critical)”,剩余的19个均为“高(High)”。

纵观全球态势,感知安全天下。悬镜安全精心筛选过去一周全球安全大事。

思科表示,成功利用这些漏洞可能允许攻击者未经授权访问受影响的设备、获得受影响设备的管理员权限、执行任意代码或发起拒绝服务(DoS)攻击。

1、3D打印机遭受远程攻击

被认为潜在威胁最大的漏洞被标识为CVE-2018-0171,也就是前面提到的3个关键漏洞中的一个,可能会威胁到到超过数百万台网络设备(主要是路由器和交换机)的安全。

据外媒报道,SANS
ISC研究员Richard和Xavier检查了曝露在公网的3D打印机OctoPrint接口,发现其中超过3700个无需身份验证即可直接访问。OctoPrint是一款免费的开源Web界面,与大多数消费级3D打印机兼容,用户可以使用它通过浏览器控制并监控3D打印机的行为。但是,无需身份验证的话,意味着随机攻击者也可以这么做。

缓冲区堆栈溢出漏洞CVE-2018-0171

图片 1

思科在发布安全公告的同时也公开致谢了 GeekPwn(国际安全极客大赛),因为其中的一些漏洞是由参加去年5月GeekPwn香港站的安全研究人员发现并提交的。

原文链接:

CVE-2018-0171就是其中的一个,它是由来自俄罗斯安全公司Embedi的安全研究员
George
Nosenko发现的。Nosenko也凭借发现这个漏洞摘得了此次大赛的“最佳技术奖”,并赢得了总计25
万元的奖金。

2、CISCO发布30项安全补丁

Nosenko表示,他在IOS 和 IOS-XE 系统 Smart Install Client
代码中发现了一个缓冲区堆栈溢出漏洞。成功利用这个漏洞可允许攻击者对设备发起拒绝服务(DoS)攻击,或在未经身份验证的情况下远程执行任意代码,这意味着攻击者可以通过利用这个漏洞来获得对受影响设备的完全控制权限。

思科发布了30项安全补丁以解决其产品中总共32个安全漏洞。其中三个为严重漏洞:Apache
Struts远程执行代码漏洞(CVE-2018-11776)、Cisco Umbrella
API未经授权的访问漏洞(CVE-2018-0435)以及Cisco路由器管理接口缓冲区溢出漏洞(CVE-2018-0423)。

Smart Install 是IOS 和 IOS-XE
系统下的一个交换机智能部署功能,可用于快速部署新的交换机,这会涉及到使用交换机的TCP
4786端口,而攻击者则可以通过远程向这个端口发送一个恶意数据包来触发这个漏洞。

图片 2

850万台设备存在易受攻击的TCP端口

另外29个漏洞中,有14个被评为高,15个被评为中等严重,解决了Cisco
Routers,Cisco Webex,Cisco
Umbrella,思科SD-WAN解决方案,思科云服务平台,思科数据中心网络等产品的安全漏洞。该公司产品安全事件响应小组称Apache
Struts正在被开发中使用,但另外两个严重漏洞目前没有被利用。

Embedi公司最初认为该漏洞只能在企业网络的内部被利用,因为在安全配置的网络中,攻击者并不能通过互联网访问到Smart
Install功能。

原文链接:

不过,在Embedi最近做了一次短暂的扫描后发现,大约有25万台易受攻击的设备以及
850 万配备有TCP 4786端口的设备在线暴露。

3、Python安装时会触发恶意代码

Embedi表示,这是一个很危险的现状。导致这种情况的出现很大可能来源于TCP
4786端口在默认情况下是敞开的,而许多网络管理员并没有注意到这一点。

Python语言允许用户安装包含在程序中的扩展包以拓展功能。执行程序时,安装包中的代码将按预期执行。但是,很多人都并不知道部分代码也可以作为扩展包本身在安装时直接执行。

事实上,现在很多思科路由器和交换机都支持Smart
Install功能。如果Embedi的猜测是正确的,那么攻击者便能够很容易利用一些搜索引擎(如Shodan)发现这些易受攻击的设备,并对设备发起攻击。

图片 3

在思科发布安全补丁之后,Embedi已经公布了该漏洞的概念验证代码。因此,各位网络管理员的当务之急是验证自己的设备是否受到该漏洞的影响并尽快安装补丁。

GitHub上一位名为mschwager的研究人员演示了一种攻击方法,该方法使用Python模块中的“setup.py”文件,以便在安装包时执行代码。使用此方法,攻击者可以将恶意代码放入可以使用root权限执行的程序包中,但并非所有程序包都需要此级别的权限。

有哪些设备受到CVE-2018-0171漏洞的影响

原文链接:

图片 4

4、Opsview监视器中存在多个漏洞

根据思科发布的公告显示,影响该漏洞影响的设备主要包括:

Opsview
Monitor是一种用于网络和应用程序的专有IT监控软件,研究人员披露了一系列漏洞,这些漏洞可以实现远程代码执行,命令执行和本地权限提升,包括CVE-2018-1614和CVE-2018-16147、CVE-2018-16146、CVE-2018-16144、CVE-2018-16145。CVE-2018-16148和CVE-2018-16147都是跨站点脚本漏洞,可以滥用来在合法用户的上下文中执行恶意Java代码;CVE-2018-16146和CVE-2018-16144可以使攻击者能够作为Nagios用户在系统上执行命令。

1、Catalyst 4500 Supervisor Engines

图片 5

2、Cisco Catalyst 3850 Series Switches

CVE-2018-16145是一个脚本修改漏洞,可能允许本地特权升级。这些漏洞影响Opsview
Monitor4.2、5.3和5.4版本,已经更新了5.3.1、5.4.2和6.0版本进行了修补。

3、Cisco Catalyst 2960 Series Switches

原文链接:

此外,具备Smart Install Client的设备也可能受到影响:

5、SSL证书暴露Tor站点的公共IP地址

1、Catalyst 4500 Supervisor Engines

安全研究人员发现了一种方法,可以轻松识别配置错误的暗网Web服务器的公共IP地址。在Tor上设置暗网的主要目的之一是难以识别网站的拥有者。为了正确匿名化暗网,管理员必须正确配置Web服务器,使其仅侦听localhost(127.0.0.1)。

2、Catalyst 3850 Series

图片 6

3、Catalyst 3750 Series

研究人员发现有许多Tor站点使用SSL证书,为了通过Internet访问,误配置了隐藏服务,用本地Apache或Nginx服务器监听任何IP地址。研究人员称这种情况很常见。当Tor隐藏服务的运营商向其站点添加SSL证书时,它们将.onion域与证书相关联。

4、Catalyst 3650 Series

如果Tor站点配置错误以便侦听公共IP地址,则包含.onion域的相同证书也将用于该IP地址。一些用户认为该研究是对Tor的攻击,但研究人员称只是试图揭示与未正确配置Tor隐藏服务相关的固有问题。

5、Catalyst 3560 Series

原文链接:

6、Catalyst 2960 Series

6、Wireshark三个DoS漏洞已出现

7、Catalyst 2975 Series

Wireshark是世界上最受欢迎的网络协议分析仪。该软件是免费和开源的。研究人员发现Wireshark存在三个严重漏洞:CVE-2018-16056、CVE-2018-16057和CVE-2018-16058,影响Wireshark的三个组件:蓝牙属性协议(ATT)解剖器,Radiotap剖析器和音频/视频分发传输协议(AVDTP)解剖器。研究人员称可以公开获得每个漏洞的概念验证(PoC)的利用代码。

8、IE 2000

图片 7

9、IE 3000

攻击者可以通过将格式错误的数据包注入网络、受影响的应用程序处理、或者诱使目标用户打开恶意数据包跟踪文件来利用这三个漏洞。

10、IE 3010

原文链接:

11、IE 4000

悬镜,北京安普诺信息技术有限公司旗下基于DevSecOps【云+端】一站式安全加固解决方案的云主机安全品牌,由北京大学白帽黑客团队“Xmirror”主导创立,核心业务主要包括悬镜云卫士、云鉴漏洞扫描云平台等自主创新产品与政企安全服务,专注为媒体云、政务云、教育云等平台用户提供创新灵活的自适应主机安全综合解决方案。返回搜狐,查看更多

12、IE 4010

责任编辑:

13、IE 5000

14、SM-ES2 SKUs

15、SM-ES3 SKUs

发表评论

电子邮件地址不会被公开。 必填项已用*标注

相关文章